How to upgrade corteza from 2021.9 to 2022.3?

Hello guys,
I wonder How to upgrade corteza from 2021.9 to 2022.3?

tried to change the version from the .env file but no luck !!

Are you using docker?


  • Use tag 2022.3.0; 2022.3 doesn’t exist.
  • don’t forget to pull and reload the configs.

Hey @tjerman , I’ve read the docs, but unfortunately, it doesn’t work

when I try it with a new(fresh) database it works
but I couldn’t upgrade it with 2021.9 database (the one that has data)!!

@yajuve yes, docker-compose

@tjerman @yajuve I tried backup my 2021.9 and then installing a fresh 2022.3.0 then restoring my 2021.9 backup to 2022.3.0

when I do the restore, the server crashes

Do you see any errors in the server console?
If not, try to log more data, do you see anything then?


@tjerman I didn’t even build the containers … I think it’s related to my deployment

will simulate everything locally and see what’s will happen

@tjerman I’m running in locally (with a backup of my database) and I get this error

server_1  | cannot upgrade postgresql schema: could not create table reports: could not add column "scenarios" to "reports": pq: column "scenarios" of relation "reports" contains null values

it’s a migration issue, any idea why?
I’m upgrading from 2021.9.1 version to 2022.3.0

follow up update for the above error

the problem
I created reports and deleted them in the past (I didn’t know how to use them!)
but in the database still exist. and due to not-null constraints in the table
and I think the corteza didn’t know how to upgrade the table so though the error

the solution
since I already deleted the reports, I hard deleted them from the table and ran the corteza again it is working

1 Like

At some point in the 2021.9 version, we added some changes to the reports table which should be covered by that specific patch release provision code.
If you upgraded from an older 2021.9 (not the latest 2021.9 patch version) that could be the reason.

Are you able to send over the DB dump just for the reports table so I can take a look if there is a more serious issue? Since you deleted them I would imagine there isn’t anything sensitive. If you prefer, you can send them privately.

@tjerman unfortunatlly, it’s already deleted!
we tried to use the reports in the past but it was very complecated to our sales team so we ignore it and we’re in a process of integerating Corteza with a BI tool

I was using 2021.9 in the .env file so I think it was 2021.9.1 version which is not the latest … I would rollout the upgrade today … and I hope everthing would be OK

I faced the same issue. Please, open your database on table reports and in scenarios column add an empty array [] as content.

1 Like

Thank you; we’ll take a look