1st user not getting expected permissions or seeign admin panels

Coming from a demo of 2020.9, I followed 2021.3 instructions for production, logged in with first user. I can see admin area, and access the user page, I can see my role is in administrators, but the behavior is not similar to the previous version I was using. It appears I have no ability to save or edit, is there something I’m missing in the documentation?

DEBUG	actionlog	service/user.go:388	failed to create users; insufficient permissions	{"timestamp": "17:22:13.189", "requestOrigin": "api/rest", "requestID": "a5f9b9744368/HQ5LzIyYix-000119", "actorIPAddr": "", "actorID": 237971631799009283, "resource": "system:user", "action": "create", "severity": 0, "error": "not allowed to create users", "description": "failed to create users; insufficient permissions", "policy-match": true, "meta": {}}

I took the entire day today to try and get this running, and have hit a wall. Thanks for your time.

I installed a fresh copy of 2021.3 today and also found the 1st user is a bit strange, like I couldn’t see create new namespace button in low code area.

But after logging out and logging in again, the system looks fine. Perhaps you may try it as a temporary workaround.

I tried that, logged out than in, than ran docker restart, than docker-compose down up, cleared cookies, and I still have not the permissions I need. Is there a docker-server command I can issue that will promote me correctly?

I really want to implement workflows.

I went down to 2020.12, creates a user, and it granted me all the permissions I needed.

I ran upgrades. That worked fine, but workflows is not in my applications list, it doesn’t seem to setup the same. I tried running the upgrade script to migrate:
docker-compose exec server corteza-server import /corteza/provision/300_automation

15:34:33.361 INFO app/boot_levels.go:160 running store update
15:34:33.362 INFO app/boot_levels.go:173 store upgrade running (to enable upgrade debug logging set UPGRADE_DEBUG=true)

Then I did docker-compose down and up, but didn’t see workflows, and automatons are disabled.

So I reinstalled 2021.3 again to see if I missed something, and got the same behavior as before. I can see the admin area, but can’t add new users, workflows, or edit fields/blocks/pages.

@jpdigi can you send me a link to the documentation you’ve followed? A quick local setup on my end worked just fine; perhaps I’m not looking at the same thing.

If you’ve done any modifications, can you send the docker-compose.yaml and .env files?

Could you also send over the server logs from when the system is initially started?
Please include LOG_DEBUG=true and LOG_LEVEL=debug into your .env.