Application-selector-icon broken when using HTTP_BASE_URL?


I set up a Corteza-installation (2021.9.4) behind my own nginx-reverse-proxy, and I’d like to use a URL-path-extention to access Corteza. This means Corteza should be accessed by

I inserted the following lines to my .env-file:

…and almost everything works very well. Corteza ist generating URLs like
correctly, I can log in and navigate with mouse-clicks in it.

With one exception:
The six dotted Application-Selector-Icon is pointing to
instead of
…so every time I click on that icon I’m leaving Corteza.

Is there any other .env-option I missed to configure, or did I really find a bug?!

[As this is my first post here: Many thanks for this really cool project!]

Thanks for the help!

Hi @Dirk

There is no other ENV var for this.
Looks like a bug and should work as you described it.

We’ll take a look.

Fixed in the git repo. Will probably be part of one of the next patch releases.

1 Like