First metric in block always 0 in 2022.3.3

Found this Project yesterday. Love the fact that is go and vue. Pretty much was i would have implemented. So i started to develop a small project i had in mind for finance tracking. Go my Sum workflow working and worked around some querks with the Subrecord creation.

However i have a field Total on the main record (calculated by button via a workflow) and i wanted to show it as Metric in big . So i created a metric Total on the main module with Filter recordID=${recordID} and Sum operator (its anyways only one) on the total field. In 2022.3.0 it was working fine. With 2022.3.3 i have to add the same metric twice and only the second one gets rendered.

is that a known issue? or what could cause this behavior

Thank you for the report, it seems filters that include ${recordID} are behaving strangely on 2022.3.
This will be fixed in 2022.3.4

thanks any idea when that version will be released?

Our release schedule is every two weeks on Wednesdays.
So you can expect the 2022.3.4-rc.1 to be released next Wednesday (29th of June)

The official 2022.3.4 release would therefore be available in ~2weeks from now.

Keep an eye here for release news

thanks appreciate the quick response

I just tested it before finishing up for today and it seems to work.
As I can see it was fixed in a 2022.3.3 hotfix.
So you can try pulling the docker image (2022.3.3) to see if it was resolved.

now it works. the image is 3days old i downloaded yesterday and the version said 2022.3.3 not sure what went wrong there. but ok cool now it looks pretty

1 Like