Having a hard time installing Locally

Following the youtube video for installing locally word to word.
Getting error:
mapping values are not allowed in this context

Can anybody help?

Hi @ajaymatharoo

this looks like docker compose configuration error -
Can you share docker-compose.yaml that file here? (you can use pastebin or similar service)

Thank you

Hi,

can you post contents of docker-compose.yaml file?

Cheers

1 Like

I shared my local configs not too long ago in this post

Hi @darh

I simply copied and pasted the code from here without any changes.
Multi-image MySQL :: Corteza Docs (cortezaproject.org)

The second one I tried from DevOps guide. The first one in the list pasted here YAML from Dev Ops Guide - Pastebin.com

Am I supposed to do something with the docker as well, like creating an image or something? I have simply installed docker and ubuntu on my windows machine @tjerman

https://docs.cortezaproject.org/corteza-docs/2021.9/devops-guide/offline-deployment/multi-mysql.html
@Strijelac

@ajaymatharoo it can happen sometimes that the editor you use to prepare the YAML file corrupts the spaces & tabs (indents) when you paste the data. Maybe that is the reason?

@ajaymatharoo could you also share the contents of the .env file (remove any secrets)?
Not too long ago I got a similar error when I forgot to specify the version in the .env so the resulting value was off.

You can also run the docker-compose config command to see the config docker-compose will use to set up your system; paste that as well please (remove any secrets).