Initial sign in to Corteza fails for me

Question on messaging by Gavin Cantley, on 23/1/21: Hi, really struggling with initial sign in to Corteza, followed production deployment instructions for 2020.12.1 version, docker-compose ps shows all healthy, but sign in fails with

Error: could not send email: gomail: could not send email 1: 550 Cannot send a message as info@example.tld. Please send as

Could anyone help me to fix this ?

I tried to set it manually with this command:

docker-compose exec server /bin/corteza-server system settings set auth.mail.from-address ‘“”’

from this thread: SMTP_FROM possibly ignored · Issue #7 · cortezaproject/corteza-server · GitHub but the path isn’t right and I’m not sure how to find it.

@Gavin Cantley your’re using your gmail for sending emails from corteza, correct?

IIRC, gmail will not allow you to send emails with “FROM” as anyone else then the acc. you’re using.

so either

  • change your SMTP provider (use local one, one given by your hosting provider or something like mailgun
  • remove SMTP_* settings to disable email confirmation
  • disable email confirmation (see in the docs how to do that)
  • change that info@example.tld to the email you’re using.

I have simlar problem with 2021.3 version. But i can log i make these steps:

docker-compose exec server server settings set auth.mail.from-address → but error Error: could not send email: gomail: could not send email 1: 550 Cannot send a message as info@example.tld. is still present
docker-compose exec server server users add root@localhost → add user
docker-compose exec server server roles useradd admins root@localhost → add role

But in admin panel i cant delete users, in low code i dont see create namespace, in namespace i cant edit modules, pages, etc.

I installed a fresh corteza 2021.03 and i cant login the first time. I needed to

corteza-server users add

then it was working. But still i couldnt add any lead, so i made

corteza-server roles useradd admins

but still i cant add no lead. What am i missing?

In the .env i changed

and i was not able to change permissions on my mac like described in DevOps guide :: Corteza Docs because i didnt understood :slight_smile: I tried chown 1001:1001 data/db in the folder of the project after creating the folders.

Thank you for your ideas!