Installed on Windows 11 using Docker (success) wanted to document the things I had to do

I’m a User Experience Architect that has left the big 5 behind to work in the charity world. I work at a non-profit doing disaster case management. We have a solution that is very expensive and drains funds like crazy for a simple database entry program. So after perusing around quite a bit, I decided to install and customize Corteza because I think it will fit my needs.

I’m on a normal small business network and wanted to run it completely internally. I couldn’t figure out a way to just run it inside the network with the default docker install. I’m sure there is a simple way, but I couldn’t figure it out. So then I decided to do the full blown ‘online’ installation of it. When I did that I would get non-stop error 500s from nginx.

  1. Start here, DevOps Guide :: Corteza Docs for the online deployment.

  2. I created the folder structure like instructed. Then I created the 2 docker-compose.yaml’s and the env and conf files. In the “.env” file under your corteza folder, change it to your domain you want to use. I didn’t have one handy, so I used a duckdns subdomain with my current IP. So as an example.

  3. So, first thing you need to do is create the network that they are going to share.

docker network create proxy
  1. Now start up the nginx docker from the docker compose. That will create a folder structure under your folder. You can start the corteza docker as well and check they are both running. If you try to go to the dns, you will get a 500 error.

  2. This step is the one that caused so much havoc for me. I struggled for hours to solve this problem. So under troubleshooting, Troubleshooting :: Corteza Docs it tells you to put a ‘location’ paragraph under the server in nginx.conf, but that didn’t work for me. Go to the nginx folder, and under that is a vhost.d folder. Paste that paragraph under the newly created default file under the last line “## End of configuration …”

location /api/websocket {
  proxy_pass http://server:80;
  proxy_http_version 1.1;
  proxy_set_header Upgrade $http_upgrade;
  proxy_set_header Connection "Upgrade";
  proxy_set_header Host $host;
}
  1. Now you can reload nginx or restart it, but if you restart it make sure you shut down Corteza docker first. I used the docke desktop app, went to the container, click on the EXEC button so I got a command line,
nginx -s reload
  1. After it reloaded, now it is working. Success! after many hours of bumping around.

Now begins the customization!