Invalid Handle Error


I have just installed Corteza in a local instance and get an Internal error “Invalid Handle” or “Handle not Unique” error when trying to create the initial user. As far as I can tell everything installed without error. The container shows in Docker and I can get to localhost:18080

When I run docker-compose ps I get: -

corteza-docker-db-1 “/docker-entrypoint.…” db running (healthy) 3306/tcp, 33060/tcp
corteza-docker-server-1 “./bin/corteza-serve…” server running (healthy)>80/tcp

I am completely new to docker so that could also explain a lot :slight_smile: However, if I look at the log file in Docker I do see there is a database connection error. I left the yaml file as is i.e. did not change database name, username or password.

Ideas anyone?


Ok, so played around a bit more and discovered I had an older version, which happened to be the default I was pointed to. Anyway, uninstalled the containers, changed the .env file to point to the newer version 2022.3.0 and it all worked!

Not sure if it was the version issue specifically but also noticed that the Mail Password for our mail server had a # in it which looked like it was being stripped out.

Have managed to create an account, received the validation email and navigated to the main page.

Let’s see how this product works.

1 Like