Issue: unknow workflow step w/o role dev/admin

Version 2021.3.5

It is not possible to execute a workflow without beeing a member of admin or developer role.
I can grant all permissions on workflows to everyone (or any other created role) but i still get the following error:

Permissions are ok, if i remove permissions on role everyone i get an error complaining about permissions. Thats correct. So it seems that developer and admin role have some kind of permission which cant be set to a “normal” role so they are able to access workflows.

What you are sharing (on the screenshot) is not permissions error. Can you double check your workflow? Is trigger “step” connected to the next step?

I know that this is no permission error. Thats what i tried to say :wink:
The roles using this workflow are ok and have all permissions. When removeing the permission i get an error complaining about permissions. Just like it should be.

Is trigger “step” connected to the next step?

Yes it is. The user needs to be member of role admin or developer and it works.
If i remove these roles from user - it does not work. I dont touch the workflow.

I even tried to setup a new role with all permissions but as you stated. Its not about the permissions.

Hi, sorry, it seems this slipped his radar. I’m looking into a similar issue now and hopefully, that will also resolve your issue.

@tnissen can you please go into the Corteza admin panel and make sure that the user you’ve used has a role that has the:

  • Search triggers,
  • Read workflow,
  • Execute workflow permissions?

Admin panel → automation → permissions

In the case that I was debugging, the role couldn’t fetch the triggers so it couldn’t start; hence that error. I think we will need to change this a little bit, but we need to sync up internally before I do anything.