mySQL user/pass

Hi, what is defaul admin user/pass Corteza is using? I suppose it’s not dbuser/dbpass as defined in .env? I tried that with workbench but it’s not working.
I’d like to reach directly to the database to be able to directly import record to one entity which is referencing other entities through fields. Out of the box import seems not supporting it.

I figured it out:
- actually IT IS dbuser/dbpass as username/password if you didn’t change before initial db:seed
- mysql port 3306 is not exposed outside container so only thing to do is add port definition to docker_compose.yaml, section db. As following (spaces needed but this text editor is ignoring so watch out if you copy-paste)

# MySQL Database
# See for details
image: percona:8.0
restart: always
- 3306:3306

Now when I’m in db I can see all the tables so I found that records are in table compose_record and values are in table compose_record_value so it would be easy to insert new records. Btw, all fields which are related to different entities has to be inserted with id’s so proper mapping has to be done upfront.
Also, I see that id in compose_record is not sequential so I’m not sure which algorithm corteza is using. I think it can be solved by import data with dummy records via corteza interface and then update missing records with queries.

… and it worked. Not elegant but efficient.

1 Like