Namespace failed to import: not unique

We are pretty new to Corteza. We have two copies of Corteza deployed, one in dev and one in staging. We have added several fields and modules to the CRM namespace in dev and added some branding/styling. We would like to copy all of these changes from dev to staging. I used the instructions here to export the namespace from dev.
I tried importing this namespace into staging as CRM2 but got an error: Namespace failed to import: not unique.
I then deleted the CRM namespace from staging and tried reimporting using different names but the import always fails with this error.
Can anyone point me to a solution?

1 Like

When importing, you should have the option to specify both the name and the handle – did you change both?

As a side note, the namespace export/import may not be the most appropriate way to manage site promotion.
We generally do this via DB dumps as we currently don’t have a proper built-in solution

Also, what version are you on? I just tried it on a fresh 2023.9 and it worked just fine.

Hello tjerman,
Thank you for the quick response. I have verified that the source and destination are both Corteza 2023.9.2.
I am guessing my issue is specific to changes that we have made to the CRM module. We have added several additional fields, etc.
I would be glad to send you the .zip exported from the source copy of Corteza, but I am new to the forum, and don’t have upload privileges yet.
Thanks again.

I have related question so posting here. Not sure how to create a new question without creating a new Category.
Exported a Namespace from Corteza Cloud and tried to import it in locally installed Corteza.
Got this error:
issue with file upload: “namespace reference must be scalar (2.5)”
What does it mean? (“must be scalar”)

1 Like

That’s a good question.
Could you screenshot your namespace edit screen (where you punch in namespace name and handle)?

I’ve encountered “Namespace failed to import: not unique” when trying to import a namespace that has EN locale information (from some partial localization). Taking it out of the yaml file and re-zipping allowed me to successfully import my namespace.

1 Like

Hmm sounds like an easter egg… would you mind opening a GitHub issue?