Running Corteza on Apple M1

In response to RFC on the documentation - #9 by mia.arh

Having moved to Apple M1 architecture I’ve found the Docker install no longer works

Are there any concrete errors that come up?
@vicky told me that the Docker setup should work as expected as long as you’re using the latest versions (there were some issues with Docker in the early days of M1).

I’ll try to set it up on my MacBook to see if everything works as it should and write down some extra notes in the docs if needed.

Hi, when I run docker-compose up I get the following error:

no matching manifest for linux/arm64/v8 in the manifest list entries

Though it appears to have installed the Intel container, which appears to be running, but if you run docker-compose ps there are no containers running.

Hey @Pointswell,

Some images don’t support the new Apple M1 Chip but this can be resolved by adding platform to your service like:

    platform: linux/amd64
    image: <NAME[:TAG|@DIGEST]>

Alternatively, you can use the following command:

docker pull --platform linux/amd64 <NAME[:TAG|@DIGEST]>
1 Like

Thanks that fixed it!