Server does not seem to persist data

I’m trying to run some test on keeping the server healthy in docker swarm and I ran into an issue.
I’m using the online setup with postgresql, postgresql persists the data and on second startup it sees that there’s already a database and uses it.
However the server tells me its using sqlite and that it’s reccomended for testing purposes only. Whenever I kill the container and start it up again I lose the logins and data.

I’ve looked into the documentation and saw no mention of this, any way to change it?

Are you sure you’ve properly configured it? Can you send over the .env and docker-compose.yaml files (please exclude any secrets).
If the server is telling you it’s using SQLite that would mean the DB_DSN is probably missing from the .env

I switched to the mysql setup and changed some settings, it works even though I still get some non critical errors, I think I should close this thread and whenever I end up stuck open a better scoped one.

Thank you