Test failed: session not found

Has anyone seen the error Test failed: session not found before?

I’m running a workflow using the play button to trigger it manually as a test. It used to work but suddenly stopped (i’ve been making changes to the workflow).

I’m making sure to keep the webappp open in another tab.
I’ve exited and reopened all my tabs, restarted the server, cleared the cache, used incognito mode, but I still get this error.

Has anyone had any resolution to this?

Help would be appreciated!


For future readers who get this error:

There was an issue with a jsenv parsing some input. Removing that workflow step fixed this error.

1 Like

Hi @shmuel , thanks for the feedback on this one, much appreciated.
Do you have a reproducible minimal workflow you can export so we could debug this more easily?

I’ve already deleted that part of my workflow. I just tried quickly to reproduce it but couldn’t.

I can give you some context though in case this comes up again.

I was trying to check if a value was blank and didn’t manage to (that’s a separate issue that I reprodued here: Workflows)

In desperation I tried using jsenv to cast a value that I expected to be null to some falsy value