Unable to create Pricebook

Hi! I’m evaluating the app deployed locally with the official docker-compose config (app + mysql) which currently builds version 2022.3.0.
While trying the unmodified CRM namespace I’m unable to create a new Pricebook, after typing some details and clicking “Save” the page just hangs there.
Attached some screenshots:

I tried to diagnose the problem a bit and it seems that the page doesn’t send a POST after clicking “Save” (as it does on other pages).
Also the page sends some errors in the browser console while loading
[See reply]

Am I missing something? Is there any setting to change?
Thanks for your help

The browser console errors while loading the page

Attached a small GIF with the error with browser console open

welcome @twinhelix to the community

I think the error happened because you’re trying to use the record variable on none-record-page

could you show me the pre-query if you have done some?

Hi! Thanks for the prompt reply.
I’m not running any pre-query or computation prior to accessing the creation page of the Pricebook.
Here is (another) short video showing the issue from the CRM main page, just after a full cache refresh (Ctrl+F5)
Peek 2022-06-06 14-34

I’ve tried the same scenario and it was saving correctly (2022.3.1)

I wonder if you have workflows triggered before-create on that module?

I’ve tried to use the version you mention (2022.3.1) and it finally works.
The errors in the console are still there and they appear in every “create” page that I could try, so it’s apparently something that the software can live without (although I think it shouldn’t be in the console :smiley: )
I don’t know when the version was changed, but the documentation needs an update. How can I help you guys with that?

1 Like

Thanks for the bug report; I can confirm the issue also appears on my end.
I’ve opened a ticket for one of the devs to look into it. It should be fixed by the next patch release 2022.3.3 scheduled on Tuesday next week.


I’m using 2022.3.3 and saving works, but editing seems to remain not functional.
Steps to reproduce:

  1. Save some Price Book Details
  2. Press Edit Button on Record page for module “Pricebook”
  3. Change some minor things (in my case adoption of Description)
  4. Press Save Button.

My Instance is running in debug mode and nothing appears on the debug console.

In my Case, I have also the same issue on

  1. Record page for module “Quote”.
    Clicking Edit and Saving does not work.
    I was editing the email of the primary contact and wanted to save it. Nothing happens.
    I was editing the taxes in Totals and saving has no effect
  2. Record page for module “Quote”


@baho can you re-pull the 2022.3.3 version and try again? We messed up a few commits and had to re-release the version.
Running docker-compose pull should pull the latest version

Yes, I can confirm, that’s working now.