What's the required environment variables for Minio storage?

Hi there

as I understand, storing static files in cloud storage is only valiable via Min.io server
I’ve deployed a server and set the following environment variables


the thing is nothing changed!
is there other variables need to be used?

1 Like

Hi munawir,

first, you need to have buckets for the webapps created, that would be at least:

  • compose
  • system

Next, do use MINIO_SECURE=false, since we do not support custom TLS with minio (for now).

After that, please check and post the logs of the minio namespace, an example would be:
15:50:33.206 INFO initializing minio {"bucket": "compose", "endpoint": "localhost:9000"}

That should do it, upload some data in compose and check in minio console or via mc.

hello @peter

so, the configuration is as follows
creating the buckets and setting these variables


regarding MINIO_ENDPOINT, it’s the domain name without HTTPS (although the Minio running on HTTPS)

the thing is that when I upload a file, I got this error message in the UI

Issue with file upload: " <html><head> <meta http-equiv="content-type" content="text/html;charset=utf-8"> <title>502 Server Error</title> </head> <body text=#000000 bgcolor=#ffffff> <h1>Error: Server Error</h1> <h2>The server encountered a temporary error and could not complete your request.<p>Please try again in 30 seconds.</h2> <h2></h2> </body></html> "

and when I check the bucket from Minio I see there the image uploaded but I can’t open it (the file is corrupted)

any idea how to overcome this?

do you think we need to configure this variable STORAGE_PATH too? if yes, what’s its value should be?

hi, one more strange scenario I’ve found

I tried to upload different files rather than an image
all failed to upload correctly except for json files (although I make them larger in size but it worked)

any idea why?

Hi @tjerman, if I remember correctly you’ve configured Minio for a demo a while back

if so, could you share with me the variables ?

additional update …

when uploading the image or pdf files, when Corteza tries to retrieve them it got 500 status in the console and the response in the console is seeker can't seek