Cannot have view of development

Hello guys,
I have set AUTH_DEVELOPMENT_MODE=true (Azure), but getting the following error when access to /auth/dev: open auth/assets/templates/scenarios.yaml: no such file or directory

Please help to solve, thank you all very much

Hi @annguyen281

Can you describe what are you trying to do?
What kind of environment are you working in (did you cloned the source or using a docker container)?

chers

Hello @darh ,

Thanks for your message
We’re using docker-compose and deploy corteza server to Azure Web App service:

> version: '3.5'
> 
> services:        
>   server:
>     image: cortezaproject/corteza:2021.9
>     restart: always
>     ports:
>       - 80
>     volumes:
>       - /data
>       - ${WEBAPP_STORAGE_HOME}/assets:/data

We’ve already set 2 env. variables:
AUTH_DEVELOPMENT_MODE=true
AUTH_ASSETS_PATH=/data

Hi,

Ok. But why setting auth dev mode to true on a production (my assumption here) env?
What would you like to achieve? Modify the login pages?

You’ll need to extract/unpack the files from the binary into a local drive and modify them there before starting the server.
https://docs.cortezaproject.org/corteza-docs/2021.9/integrator-guide/personalization/auth.html#_enable_personalization

I would recommend you do this on your local development env and modify the (auth template and css) files there. When you’re happy with the changes, move the files to production env and set ONLY the AUTH_ASSETS_PATH to that it points to location where the files are.

Hope this makes sense.
See the docs (link above) for more details.