Date selection error after upgrade to 2022.3.1

Seems i have run into another issue with upgrading Corteza and doing a restore of data.

  1. clean install of v2022.3.1
  2. go to opportunities, add a record and save.
  3. edit opportunity and select a new “close date” field value, selection works fine.
  4. restore data from previous version (2021.9.6)
  5. do same steps 2 to 3., problem is selection of date from calendar causes “frozen” page, only way to stop is kill the tab/browser.

i also tried install 2021.9.8 and restore data.
this works fine. date field selection works.
i change the file .env to version 2022.2.1, upgrade works.
but the date field selection is still broken

I could not replicate the issue with 2021.9.6 data
Could you share the value of the date field from the previous version?
Would help me break it down

one of the values is 3/4/21.
i forgot to mention this is the mysql version
i found this in the backup .sql file with one of the opportunity records?:
(i couldnt tell the begin from end since its one big string)

{“name”: “CloseDate”, “value”: “2021-03-10”}, {“name”: “Description”, “value”: “

”}, {“name”: “EndDate”, “value”: “2021-06-30”}, {“name”: “Name”, “value”: “Grid Modernization T&M Q2 2021”}, {“name”: “OwnerId”, “value”: “218846202391691268”}, {“name”: “Probability”, “value”: “100”}, {“name”: “RecordHealth”, “value”: “Green”}, {“name”: “StageName”, “value”: “Closed Won”}, {“name”: “StartDate”, “value”: “2021-04-01”}],

i pasted wrong value: (let me know if you need more of the string

{“kind”: “DateTime”, “name”: “CloseDate”, “label”: “Close Date”, “fieldID”: “218722437238554628”, “isMulti”: false, “options”: {“format”: “YYYY-MM”, “onlyDate”: true, “onlyTime”: false, “multiDelimiter”: “\n”, “onlyPastValues”: false, “outputRelative”: false, “onlyFutureValues”: false},

218722440644919300,218722440476426244,11,‘DateTime’,’{“onlyDate”: true}’,‘null’,’{}’,‘CloseDate’,‘Close Date’,0,0,0,0,‘2021-02-17 21:32:14’,NULL,NULL)

I tried with your exact setup and values and it works as expected without freezing
Which browser are you using, have you tried a different one?

i tried all 3 (chrome,firefox and edge), same freezing on date selection calendar

The only other thing i can think of was that we were originally on version 2020.12 and upgraded to 2021.9.
there was a problem with this upgraded also after doing a restore of data. the workflows were missing so i had to export the workflows from a clean install and re-import after the restore.
and now upgrading to 2022.3 from 2021.9

Just to double check, could you submit just the value of the CloseDate saved in the DB.
The easiest way to do this is open the network tab in chrome (F12-> network), reload the record page (F5) and find the request for the record in the list of requests.

You will know you got the right thing when you click on the request and click on its preview tab, you will see the values array with {name: "CloseDate", value: "2022-05-20T22:00:00Z"}.

Paste this line here so I can see the value format. Im not 100% sure by the things you provided above.


is same

  1. 2: {name: “CloseDate”, value: “2021-03-04”}

  2. name: “CloseDate”

  3. value: “2021-03-04”

Tried using the same value and configuration. All works as expected.
I even tried it on mobile.

Does creating a new record and picking its date, then updating it work for you?
Or does that freeze it too?

adding a new oppertunity does same freeze when trying to edit.

is there a way to do a partial backup my data so you can import?
i cant give you entire backup for privacy reasons.
the sql backup file seems to be a gigantic string for insert…hard to format, edit

does it matter that 2022.3 has a different “request” javascript?

this is weird, but fixes issue.
I went into modules and removed/re-added as diff name/renamed back to CloseDate from opportunity page. CloseDate Works (can select a date), but “Start Date” (original field) freezes.
but notice the UI, something is telling module to format/show the date differently.

i think i found the bug.
i did a clean install of 2022.3


if you go into modules and select a date field, and check the “Date Only”.
then go back and edit an opportunity, edit closedate, the first select works, but select a date again (without exit page) and it freezes.

I just tried that on a clean 2022.3 install and no freeze
Not sure why, but your system doesn’t like our datepicker

the first time works, second time doesnt.
second time meaning select a date, then select another date again without doing anything else
my input screen didnt have the “hour” portion

Yup i selected it two times, could you try it on a different PC per chance. All of our instances use 2022.3.1 and i couldn’t replicate it on any of them.

I see you’re using a localhost instance, that could also be an issue. If you don’t use it straight from docker that is. Not sure what your setup is.

i was using a localhost (offline version) because i did not want to affect the production server while trying to debug.

yes, its a docker container, i did a docker prune of image/volume/container to clear data.
using default .env and yaml.

anything i can do on my side to “clear” or reset the calendar picker?
(besides what i was doing of unchecking “Date Only” and saving)

I currently have no idea what could be causing this on your end.
If you have a workaround feel free to use it.
Try to connect to an instance from a different PC and report back if it freezes there for you too.

Hello! i have the same issue, upgraded from 2021.9.8 using docker-compose to 2022.3.2, everything works fine except the date picker, the moment i try to select a new date it freezes the tab.

Doesn’t give any error or anything explicit, just freezes the tab in the moment i select a new date…

Windows 10, Firefox 100.0.1 (64-bits)

Update: tested with chromium and it still freezes

Update 2: disabling the “date only” allows to place the date without freezing the tab, but you have to also set the time.

Update 3: enabling the “date only” again makes it freeze again.

Welp looks like the workaround for now is to disable the “date only” option