Unable to access Corteza

I have recently moved all of my web files over to a new server, however, due to the issues I have had upgrading Corteza, I have left the Corteza on the old server to continue using at present with the intention of installing the up-to-date version on the new server and moving everything over.

The problem I am having is that, before I got the new server and transferred my domain over, Corteza was accessed via - corteza.domain.com and the API was linked to api-corteza.domain.com

The problem I am experiencing is that, domain.com is no longer hosted on this server.

I have tried accessing corteza via ip:port but it does not load I get an error This site cannot be reached

I have checked docker ps and the containers are running, it just appears to be the accessing that is causing problems

My ENV file

# Version of Corteza Docker images
Domain=corteza.domain.com (Tried changing this to IP but made no difference)
`# Database connection` `DB_DSN=db details` `AUTH_JWT_SECRET=secret` `LOG_LEVEL=info`

My YAML file

version: '3.5'

image: percona:8.0
restart: on-failure
# To be picked up by percona image when creating the database
# Must match with DB_DSN settings inside .env
# healthcheck: { test: ["CMD", "mysqladmin" ,"ping", "-h", "IP"], timeout: 20s, retries: 10 }
# Uncomment to use local fs for data persistence
volumes: [ "./data/db:/var/lib/mysql" ]
networks: [ internal ]

image: cortezaproject/corteza-server:2020.12
restart: on-failure
env_file: [ .env ]
# Informing Corredor where it he contact us
CORREDOR_ADDR: "corredor:80"
VIRTUAL_HOST: "https://corteza.domain.com"
depends_on: [ db, corredor ]
volumes: [ "./data/server:/data" ]
healthcheck: { test: ["CMD", "mysqladmin" ,"ping", "-h", "localhost"], timeout: 20s, retries: 10 }
ports: [ "" ]
networks: [ internal ]

image: cortezaproject/corteza-server-corredor:2020.12
restart: on-failure
env_file: [ .env ]
# Informing Corredor where it he contact us
CORREDOR_ADDR: "corredor:80"
# Binds internal port to port LOCAL_DEMO_CRD_PORT on localhost
networks: [ internal ]
volumes: [ "./corredor:/corredor/usr" ]

image: cortezaproject/corteza-webapp:2020.12
restart: on-failure
depends_on: [ server ]
# Monolith server in the backend, all services can be found under one base URL
# Configure web application with API location
API_BASEURL: "api-corteza.domain.com"
VIRTUAL_HOST: corteza.domain.com
ports: [ "" ]

internal: {}

I have a feeling it has something to do with the API_BASEURL and VIRTUAL_HOST but am unsure and also not 100% sure what to change them to

I have been able to access all the other containers using the IP and the Port, but I am unable to do this with Corteza.
Could someone advise what I need to change in my configuration files in order to gain access?

It wont let me edit the question to add info…

I have also tried taking all of my files (YAML, .env, DBs) over to the new server, creating the container there but again, corteza fails to load.
Is there something I need to change for Corteza to recognise the new server IP?orteza now loads but I get:

I am using the exact same YAML and env file from the old server and have also ported over all of the volumes etc

Is there something else I need to do in order to be able to access?

The problem appears to be Percona,
I am thinking that it is something to do with the image communicating with the main server.
When I run docker-compose ps all images are running but Percona is constantly restarting


mysqld: Can't create/write to file '/var/lib/mysql/is_writable' (OS errno 13 - Permission denied)
2022-07-04T17:54:35.904588Z 0 [System] [MY-013169] [Server] /usr/sbin/mysqld (mysqld 8.0.28-20) initializing of server in progress as process 15
2022-07-04T17:54:35.907285Z 0 [ERROR] [MY-010460] [Server] --initialize specified but the data directory exists and is not writable. Aborting.
2022-07-04T17:54:35.907299Z 0 [ERROR] [MY-013236] [Server] The designated data directory /var/lib/mysql/ is unusable. You can remove all files that the server added to it.
2022-07-04T17:54:35.907378Z 0 [ERROR] [MY-010119] [Server] Aborting
2022-07-04T17:54:35.907726Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.28-20)  Percona Server (GPL), Release 20, Revision fd4b5a776a6.