Can someone please install Corteza on google cloud/ digital ocean or Oracle cloud

Please help me install production instance on google cloud, digital ocean or Oracke cloud.

I have been struggling to do it for the past month now and the forum is helping but to no success.

I dont want to use the online corteza option because i dont know if i will struggle to get it onto my own server after i have it ready to deploy from the online option.

I can do a local installation easy but how do i push that local copy online to run it from one of the servers mentioned above? I keep getting problems for nginx and other issues.

If someone can help me im willing to pay, i really want to use corteza.

Or can i build locally and then clone that copy to the online version and is deployment onto my own server easy using the online version?

I’d be open to help you out at no cost over a video stream or something. I can’t guarantee i’ll help you see it all the way through but I can def give you a little more clarity into the nature of your problem.

It’s been roughly a year since I’ve had it up and running in a production environment but I have been thinking about spinning it back up so that I can trial some functionality to a local non-profit i’m volunteering my efforts too. Drop a contact and I can try to reach out.

Have you looked at the caprover instance of Corteza? Many packages/one-click-apps are outdated or outright broken without some tweaks but it’s a lot easier to get a handle on how the docker files + environment variables + nginx configs fit together since it’s pretty much a ‘bare-metal’ docker host and not a docker-as-a-service platform (if you want to call it that) where one logged error can tank the whole system.

2 Likes

Hi,

this is Iveta from Planet Crust’s sales department.

What you’re describing seems all doable in Corteza, I am happy to set up a call to discuss how best we can help.

Please, let me know your phone number and time when I can reach you best.

Feel free to reach me directly at iveta.fleming@planetcrust.com.

Kind regards,

Iveta

2 Likes

Thanks for the reply Iveta, I have sent you an email

Hi Nick, thanks for the reply, really appreciate it.

I have managed to install the nginx and corteza onto my oracle cloud instance and also changed my dns settings for my domain registrar but still im missing something because if Im going to the domain I get “the site cant be reached”

Am i pointing the dns wrong or did I do the installation wrong

Hey :slight_smile:
It would appear the DNS configuration is incorrect, is the instance and the domain with the same provider or are you required to configure Domain specifics such as NS records etc?

And if you were to use the public IP assigned to the domain and try SSH to the instance are you able to reach the instance? Looking at the trace routes while you are troubleshooting the domains might be worthwhile.

Hey Andre…

No im using domains.co.za as my domain registrar and i want to use google cloud as the host or even Oracle cloud whichever is cheaper.

To answer your question yes i am able to ssh into the instance… i made a detailed summary of what I’ve done so far meaby if you can have a look there and see what am I missing or doing wrong?

Hi Andre,
Please I would really appreciate it if you can help me, I will send you a private message now.

I first tried this:

to no success and now im trying this with abit more success but still going nowhere:
This is what I have tried now and I’m really about to give up with corteza completely as i’m just stuck in a installation loop the whole time

Somewhere im not understanding something, whether its related to the ports or how to connect to the container i have no idea

Would appreciate your help please